NetXMS 4.2 release notes

4.2.461

2022-12-06
  • Improved dashboard element "status indicator"
  • Improved SMSEagle notification channel driver
  • Fixed random zero values returned by Linux agent for file system space metrics
  • Fixed copy MAC in FDB table
  • Fixed server certificate monitoring template
Fixed issues (4)
  • NX-2056 (Create DCI status indicator dashboard element)
  • NX-2326 (Add parameter in log parser events that contains file name)
  • NX-2346 (Unexpected SNMPv3 authentication failures)
  • NX-2349 (NXSL $node->executeAgentCommand() crashing server)

4.2.433

  • Driver for Juniper Networks devices retrieves product information from vendor MIB
  • Empty source/tag is processed as match any source/tag for Windows Event Log and syslog parser
  • Configurable maximum message size for client connections
  • "Follow location" option for web services
  • Fixed server crash after DB connection loss
  • Fixed server deadlock within topology poll
  • Fixed web application property reading from JNDI and properties file
Fixed issues (5)
  • NX-2278 (Support for hexadecimal encoding of OCTET STRING in nxsnmpset)
  • NX-2298 (Alphabetize Source Objects in Event Processing Policy)
  • NX-2315 (Chained import in NXSL is not working)
  • NX-2321 (History for a Table DCI value shown as empty)
  • NX-2333 (Data collection error thresholds show up as "error(1) < 0")

4.2.395

2022-10-21
  • Context dashboards
  • Out of the box access to OSPF information on routers
  • Automatic OSPF topology maps
  • TCP port forwarding for object tools of type "local command" and "URL"
  • "Spread" operation for arrays in NXSL
  • New methods executeAgentCommand and executeAgentCommandWithOutput in NXSL class "Node"
  • Simplified data collection configuration for MQTT sources
  • Notification channel driver for MQTT
  • Automatic binding on configuration poll works again (but can be switched off in configuration)
  • Added driver for Teltonika modems
  • Improved database write performance on TimescaleDB and PostgreSQL
  • Reduced memory consumption by server's background database writer
  • Improved UI for two-factor authentication
  • Improved D-Link driver
  • Agent saves backup copy of it's ID on file system
  • Reworked general data collection object property page
  • Added internal monitoring metrics for server certificate expiration date
  • Built-in TFTP support
  • Fixed network map issues with link duplicates on auto populated maps
  • Fixed network map clone
  • NXSL function JsonParse correctly handles JSON documents with array as top level element
  • Custom error message can be provided in NXSL statement abort
  • Operator new in NXSL can be omitted
  • NXSL VM automatically loads stdlib module if it's available in the script library
  • Improved DCI format strings (usage of unit names and multipliers can be controlled)
  • Agent manager view updates automatically on tunnel open or close
  • Added Organizationally Unique Identifier lookup
Fixed issues (29)
  • NX-648 (DCI units and binary prefix)
  • NX-702 (DCI option - "Store only if value changes")
  • NX-708 (Add map option to make all labels non-transparent)
  • NX-826 (Show chart title in dashboard elements editor)
  • NX-1279 (WebUI does not support ServerName/ServerColor options)
  • NX-1474 (Execute server script - replace error message box with alternative way)
  • NX-1527 (Option to hide DCIs from templates or created by instance discovery)
  • NX-1560 (List of custom agent ports to be used during network discovery and configuration polls)
  • NX-1632 (NetXMS agent service is disabled after installing netxms-agent deb package on Debian 9)
  • NX-1809 (Center Map Background Image)
  • NX-2044 (Object Tool to run against container)
  • NX-2078 (Add the ability to specify an alias when creating an object)
  • NX-2103 (Add ability to push values to Push DCIs from log file parser)
  • NX-2140 (Export result of the package deployment to CSV)
  • NX-2234 (With a drop-down menu with a choice of DCI metrics, swap the display of Description and Name (Parameter))
  • NX-2237 (Add the ability to set height for passive elements in rack and use custom picture)
  • NX-2251 (Add 'conflict' marker to inherited custom attributes)
  • NX-2259 (Configurable server's SNMPv3 engine ID)
  • NX-2261 (Access to MikroTik metrics via network driver metrics)
  • NX-2266 (Add agent metric similar to System.IO.Devices but including sub-devices)
  • NX-2273 (2FA method can't be removed in user editor)
  • NX-2274 (2FA - unable to add failed method in user editor - it's silently ignored)
  • NX-2281 (Action message should be multiline field)
  • NX-2288 (External parameter redirect issue on Ubuntu 22.04 LTS)
  • NX-2302 (NXSL function PollerTrace is not working in template auto-apply poll)
  • NX-2304 (Improved script execution options for nxadm)
  • NX-2306 (Node configuration poll don't update information about interfaces type)
  • NX-2308 (LDAP user sync login error should be logged at lower level)
  • NX-2309 (No scrolling or resize for ports part in VLAN view)