NetXMS 4.1 release notes

4.1.420

2022-07-28
  • Optimized alarm resolve/terminate using regular expressions
  • Improved topology detection on Juniper switches
  • Fixed communication protocol compatibility issues in C++ client library and command line client tools
  • Fixed business service default retention time for historical data
Fixed issues (4)
  • NX-627 (Gauge rendered incorrectly)
  • NX-846 (Ability to copy to clipboard in Routing Table and FDB views)
  • NX-1077 (Option to copy MAC address to clipboard in FDB view)
  • NX-2283 (Show version in debug console)

4.1.404

2022-07-28
  • Fixed full screen dashboard display on startup in desktop client
  • Improved database consistency checks for business services
  • Added Oracle driver option to disable OCI statement caching
  • Fixed slow appearance of discovered nodes
  • Fixed bugs in database schema upgrade from pre-4.0 versions
  • Fixed bug in map options property page
  • Fixed incorrect string encoding during SNMP SET operation
  • Fixed sqlite upgrade issues
Fixed issues (1)
  • NX-755 (Network discovery may not stop immediately)

4.1.377

2022-06-09
  • Agent configuration option to disable local database
  • Linux subagent can read software inventory from OpenWrt package manager
  • Added driver for HPE iLO
  • Fixed incorrect return code of NXSL function SNMPSet and method set in SNMP transport
  • Original DCI string value returned by transformation script is preserved
  • Fixed bug in downtime calculation for hierarchical business services
Fixed issues (1)
  • NX-2262 (syncUserDatabase() does not wait for CMD_USER_DB_EOF)

4.1.333

2022-06-09
  • Added support for package type "zip"
  • Fixed incorrect label colors on dashboards after migration from 4.0
  • Minimum number of bytes required for MAC address search reduced to two
  • Reading of ipAddrTable and/or ipAddressTable during configuration poll can be disabled via custom attributes
  • Fixed server crash caused by incorrect value of configuration parameter ICMP.PingSize
  • Multiple fixes and improvements in new UI
Fixed issues (3)
  • NX-2089 (Bundle prunmgr.exe with web-ui installer)
  • NX-2250 (Show VLAN information on interface overview page)
  • NX-2258 (No context menu on area of interactive dashboard graphs)

4.1.283

2022-05-13
  • Maintenance journals for objects
  • SSH connectivity checked as part of status and configuration polls
  • Runtime errors in filtering scripts interpreted as "ignore" if applicable and otherwise as "block"
  • Authentication option (on by default) for local server console (accessible via nxadm)
  • Added driver for Ubiquiti EdgeSwitch switches
  • Octal numeric constants removed from NXSL
  • New string method equals in NXSL
  • Jira connector supports Jira Cloud
  • Internal metrics for monitoring notification channels
  • Improved titles in dashboard elements
  • Ignore IP addresses found during network discovery on interfaces marked as excluded from topology
  • New server configuration variables:
    • AgentTunnels.Certificates.ReissueInterval
    • AgentTunnels.Certificates.ValidityPeriod
  • Fixed DCI creation from NXSL
  • Added $dci variable to DCI script
  • Added option to configure column data type for external table
Fixed issues (28)
  • NX-1115 (JIRA configuration parameters re-read only on restart)
  • NX-1183 (Add option to choose automatic colors for instances in performance tabs)
  • NX-1734 (Add column "Peer Interface" to interface list view)
  • NX-1785 (Automatic color assignment for items on performance tab graph)
  • NX-1802 (Binary data support in NXSL SNMP functions)
  • NX-2021 (Title is not displayed for some Dashboard elements)
  • NX-2154 (Node search by partial MAC address)
  • NX-2163 (Show user name on process tab)
  • NX-2165 ("Show file" in file manager displays incorrect progress bar message)
  • NX-2196 (Keep SNMP alias separately in interface object)
  • NX-2215 (Extract XMPP related code into a notification channel driver)
  • NX-2216 (Telegram notification channel should throttle message sending and retry sending after timeout)
  • NX-2220 (Add timer key column to Scheduled Tasks)
  • NX-2223 (Notification log view should have multi-line preview panel)
  • NX-2225 (Maintenance journal)
  • NX-2226 (Agent policy move to TemplateGroup)
  • NX-2229 (Add scrollbar and ability to resize to script editor in Object Query)
  • NX-2230 (Business service enhancements)
  • NX-2231 (Use TCP/UDP for active network discovery)
  • NX-2233 (Add new agent metric similar to Service.Check() that would follow redirects)
  • NX-2239 (Node SSH polling)
  • NX-2240 (Changes to DCI comments in template are not synchronized with DCIs created from that template)
  • NX-2242 (On Windows, if agent action calls .cmd file and that file produces output, execution fails)
  • NX-2252 (TLS.Certificate.* 500 internal error to some domains when nginx enabled ssl_reject_handshake on)
  • NX-2254 (LDAP synchronization error events generated for any LDAP user login error)
  • NX-2255 (SQL issues with server_action_execution_log)
  • NX-2256 (Have two separate certificates on server - for TLS connection and to issue agent certificates)
  • NX-2257 (PostgreSQL.Version returns 0.0 if database is not connected)