NetXMS 3.9 release notes

3.9.420

2021-12-19
  • New agent command line option -Q (query values of configuration entry)
  • Windows service start mode can be changed from UI
  • Improved web API for accessing collected DCI data
  • Improved file transfer on slow links
  • Fixed bug in network topology discovery
Fixed issues (10)
  • NX-290 (SSL Certificate expiration check)
  • NX-781 (Convert to template item work incorrectly on cluster nodes)
  • NX-1032 (Threshold violations are not shown for table DCIs)
  • NX-1551 (Multiple execution completion dialogs after executing object tool on container)
  • NX-1587 (Fix MySQL error: The INFORMATION_SCHEMA.GLOBAL_STATUS feature is disabled; see the documentation for show_compatibility_56)
  • NX-2122 (Table DCI last values are not loaded on server start)
  • NX-2152 (Map should zoom in relation to mouse cursor, not center of map view)
  • NX-2175 (Add hint to SNMP Trap Transformation Script editor)
  • NX-2182 (Changing Objects.Nodes.ResolveNames actually requires server restart, but should work without server restart)
  • NX-2183 (Daily Email Summary doesn't seem to resolve users properly in "Ack/Resolved by" column)

3.9.361

2021-11-23
  • Custom port number can be specified in MySQL and MariaDB database drivers
  • MySQL subagent can be switched to use MariaDB driver
  • Fixed bug in housekeeper (expired DCI data may not be deleted)
  • Object filtering in object tree by exact IP address
  • State filter in /objects endpoint in web API
Fixed issues (8)
  • NX-30 (Show thresholds on graph is broken)
  • NX-127 (Implement System.CPU.Usage.IoWait in Solaris subagent)
  • NX-1448 (It is not possible to specify semicolon as external table separator)
  • NX-1450 (External parameters that returns process exit code)
  • NX-2157 (Macros are not expanded when uploading file via file delivery policy)
  • NX-2166 ("Hide value on last values" does not work)
  • NX-2168 (Divide by zero on core start)
  • NX-2170 (Macros in shell notification channel are not resolved)

3.9.334

2021-11-01
  • Fixed bar gauge color selection by active DCI threshold
  • Bundled SQLite updated to version 3.36.0
  • Windows crash dump handler writes compressed dump files
  • Improved Juniper driver
  • NXSL methods enableConfigurationPolling and enableStatusPolling moved from class Node to class DataCollectionTarget
  • New method enableDataCollection in NXSL class DataCollectionTarget
  • New agent parameters System.CurrentDate and System.TimeZone
  • Fixed bug in cluster resource selection for table DCI
  • Fixed possible server deadlock when zone proxies are in use
Fixed issues (10)
  • NX-2107 (SQL error on server startup)
  • NX-2128 (Disabled DCIs with instance discovery generate instance DCIs)
  • NX-2131 (Migration from psql-timescale to psql is broken)
  • NX-2132 (nxdbmgr check should not delete orphaned idata/tdata records on Timescale database)
  • NX-2143 (MIB Explorer "Create Data Collection item..." reports error on Retention time 0 or blank, but is added as "default")
  • NX-2144 (Graph Title in Web GUI is truncated, seemingly due to an ampersand)
  • NX-2145 (Update HP iLO Template to include support for HP iLOs on G10 servers)
  • NX-2148 (MIB compiler throws syntax error if statements in TEXTUAL-CONVENTION definition are in non-standard order)
  • NX-2149 (Custom Attribute Inheritance - detached inherited custom attribute not deletable)
  • NX-2150 (nxshell session.modifyObject produces Variable not found exception with setSnmpAuthName)

3.9.298

  • Improved file delivery policy editor
  • Fixed bug in centralized agent upgrade on Windows
  • New endpoint /events in web API for sending events
  • Filtering by primary host name in web API endpoint /objects
  • Fixed session agent crash on 32 bit Windows systems
Fixed issues (4)
  • NX-2129 (File delivery policy on Windows Agent causing .part0 to be added to the filename)
  • NX-2130 (If file in file delivery policy is updated new version is appended to the old one instead of replacing it)
  • NX-2133 (Set subagent column as instance on table Agent.SubAgents)
  • NX-2134 (Agent crashes if invalid owner or group set in file delivery policy)

3.9.280

2021-09-27
  • Service manager view for nodes
  • External audit logging via LEEF protocol
  • Improved process table in Windows agent
  • Windows service manager in GUI
  • Process manager in GUI
  • Optimized working with ICMP
  • Object alias shown in geo map tooltips
  • Geo map tooltips work in web UI
  • Added option to hide other objects in object's geo location view
  • Object names can be shown on geo maps
  • Fixed issues with Chassis/Rack placement properties page save
  • Fixed bug in standard deviation calculation in ping subagent
  • Fixed incorrect limit on dashboard element span in UI property page
  • Fixed file transfer issue when upgrading agents from Package Manager
Fixed issues (7)
  • NX-2050 (Show Node alias on Status Map widget)
  • NX-2115 (Allow adding image in chassis properties without selecting a rack)
  • NX-2118 (Changes in ICMP statistic collection period are not applied until server restart)
  • NX-2119 (Agent table "ICMP.Targets" should have "Standard deviation" column)
  • NX-2121 (Status map view should show node aliases)
  • NX-2124 (Log parser hangs on lines longer than 4095 characters)
  • NX-2125 (Server incorrectly reads IP network mask from VMWare ESXi and vCenter)

3.9.235

  • Fixed bug in NXSL function trim
Fixed issues (1)
  • NX-2108 (3.9.229 Cannot start process (No such file or directory))

3.9.229

2021-09-06
  • Dashboards can be saved as images in desktop UI
  • Database manager checks for access point objects without valid parent node
  • Server does not report duplicate MAC addresses if interfaces are from same node
  • New agent actions: Process.Terminate, Service.Start, Service.Stop
  • Web API session inactivity timeout can be configured
  • Fixed server deadlock related to multi-zone configuration
  • Fixed bugs in external command execution
  • Fixed small issues in influxdb driver
  • Fixed deleted form network map object list load from database on startup
  • Fixed rack placement object property page save
  • Fixed bug in SQLite driver (incorrect reading of fields with null value)
Fixed issues (4)
  • NX-1625 (Icmp.MovingAvgPingTime(*) need a way to specify sample size)
  • NX-2092 (Keep last known topology information when node goes down)
  • NX-2093 (Add new parameter to ping subagent that will calculate jitter as moving average on response time deltas)
  • NX-2101 ("Compile script" button should not be present in script preview in EPP rule list)

3.9.178

  • Server installer on Windows has database initialization task unchecked when upgrading from pre-3.9 version

3.9.176

2021-08-05
  • Added option to push DCI data using Web API
  • Fixed bug in file transfer to agent on Windows
  • Fixed agent crash if file template is used in logwatch subagent
  • Fixed object tools in alarm browser
  • Server configuration tree logged on startup
Fixed issues (2)
  • NX-2094 (Error ORA-01476 in Oracle subagent)
  • NX-2097 (Server and agent cannot load configuration if it is a symbolic link)

3.9.156

2021-07-27
  • Predefined object queries
  • LDAP synchronization filter
  • User's email and phone number synchronized with LDAP
  • Bind9 subagent rewritten in C++ and uses HTTP API
  • New NXSL function replace
  • Added Geolocation.History.RetentionTime server configuration parameter and geolocation history clearing by housekeeper
  • Added percentage value to pie chart
  • Added drill down object for tube and pie charts
  • Network map link color can be defined by script
  • Added method to get all tooltip data of the network map in one request
  • New NXSL functions to make web service custom requests (GET, POST, PUT, PATCH, DELETE)
  • JQ used for json parsing in web service requests
  • NXSL function assert() accepts second argument - diagnostic message
  • If agent configuration contains errors agent starts anyway and reports configuration load failure
  • Agent configuration tree logged on startup
  • Fixed broken "Responsible Users" object property page
  • Object management endpoints in web API
  • Source build configuration script do not throw error if libjq, libcurl, libssh, libmosquitto, or OpenLDAP are not available unless they are explicitly required
  • Cambium ePMP driver can read geo coordinates from device
  • Improved InfluxDB driver
Fixed issues (19)
  • NX-408 (Alarm log columns Ack by/Resolved by/Terminated by contain "admin" if not set)
  • NX-1548 (Allow monitoring of dynamic number of logs via Logwatch)
  • NX-1899 (Add description filter to Summary Table column definition)
  • NX-1903 (REST API AdHoc Summary Table - add ability to filter dci on description instead of just dciName)
  • NX-1964 (Windows installer unable to create user on MySQL 8)
  • NX-1995 (Create object endpoint for REST API)
  • NX-2030 (Use last known coordinates when re-adding node to network map)
  • NX-2046 (Get remote file fingerprint using file manager)
  • NX-2059 (Predefined object queries)
  • NX-2061 (Add changing file owner and changing file permissions functionality to file delivery policy)
  • NX-2063 (Detect conversion from group to super group in Telegram notification channel)
  • NX-2070 (Add notification log and server action execution log)
  • NX-2073 (Generate event when duplicate MAC address is detected on the network)
  • NX-2074 (DCI Table Last Value Column Widths are very large)
  • NX-2082 (File upload should support resume and consistency checks)
  • NX-2083 (Alarm list scrolls when alarms being added or removed)
  • NX-2086 (Notification channel driver for Google Chat)
  • NX-2087 (Incorrect values reported by WindowsFirewall.State)
  • NX-2088 (PostgreSQL driver reporting internal error "pResult is NULL in DrvExecute")