NetXMS 2.2 release notes

2.2.17

  • Fixed multiple MQTT broker connection support
  • Java 12 supported by reporting server
  • Fixed bug in agent file download to UI
  • Implemented per-device I/O counters on Windows
  • Fixed bugs in TCP proxy
  • Added object filtering by zone in REST API
  • Fixed server crash when using "SSH" or "device driver" DCI source

2.2.16

  • Improved systemd integration
  • Agent table System.InstalledProducts supported on AIX and FreeBSD
Fixed issues (8)
  • NX-857 (Server should send SNMP timeout to proxy agent)
  • NX-869 (nxevent sometimes hangs after sending event)
  • NX-1606 (DefaultInterfaceExpectedState - wrong values)
  • NX-1624 (Add "for the last minute" to description of Icmp.* per-minute agent parameters)
  • NX-1633 (Add option to "nxdbmgr export" which will skip selected tables)
  • NX-1646 (Agent can't start with invalid entry in the configuration file)
  • NX-1651 ("Thresholds" not updating live)
  • NX-1655 (Agent's parameters for network interfaces always return error on Solaris 11)

2.2.15

  • Improved driver for Cisco Small Business switches
Fixed issues (6)
  • NX-1609 (Duplicate server configuration parameters)
  • NX-1627 (Proxy node should not ping through itself)
  • NX-1637 (Unrecognized Cisco SG Switch)
  • NX-1639 (NXSL persistent storage entries not saved in database)
  • NX-1644 (DB gets corrupted when adding container/nodes)
  • NX-1645 (Broken UI element layout in table DCI "General" property page)

2.2.14

  • Local cache on agent side for data pushed with nxapush
  • Support for statsite sink format in nxapush
  • Updated default MIB collection
  • nxget command line option to print table as delimited text
  • Drill down dashboard or network map for "Gauge" dashboard element
  • Added trigonometric functions (sin, cos, tan, asin, acos, atan, sinh, cosh, tanh) to NXSL
  • Improved configuration import
  • Implemented parameter Process.WkSet on AIX
  • Additional system information parameters on Windows
  • Added NXSL hook for subnet creation
  • Interface object properties can be changed inside interface creation hook
  • Improvements in web service API
  • Support for migration to and from TimescaleDB in nxdbmgr
Fixed issues (14)
  • NX-1537 ("Hidden" flag for DCI)
  • NX-1574 (Add hasActiveThreshold attribute/method to DCI object accessible in NXSL)
  • NX-1576 (Add $2 to instance DCI script hint)
  • NX-1577 (Server configuration parameter TopologyExpirationTime renamed to Topology.AdHocRequest.ExpirationTime)
  • NX-1580 (Updated FOUNDRY MIB // Updated CPQHOST MIB)
  • NX-1586 (Comments field when putting node into maintenance mode)
  • NX-1588 (Object load error can cause server crash)
  • NX-1590 (SecondsToUptime function: Incorrect display in some cases)
  • NX-1593 (Create separate access right for configuration import)
  • NX-1603 (Windows Server 2019 is being detected as Windows Server 2016)
  • NX-1604 (ICMP sub-agent automatic targets may be deleted immediately after creation)
  • NX-1605 (MariaDB driver - TLS connections don't work)
  • NX-1608 (Support for PtP subnets /31 and /127)
  • NX-1614 (Improvements to DNS monitoring / resolving)

2.2.13

  • TimescaleDB supported as backend database
  • Added option to show SELECT output in nxdbmgr batch
  • New attribute parameterNames in NXSL class Event
  • New attribute instanceData in NXSL class DCI
  • Added option to play alarm notification sound only for active dashboard
  • Required object access is "read" for all forced polls except full configuration poll which requires "modify" access
  • Improved server startup and shutdown time
  • Added option to save network map as image file
  • New nxmc command line options -take-map-snapshot and -exit-after-open
  • Access to dependent nodes list from NXSL and Java API
Fixed issues (10)
  • NX-241 ("nxdbmgr batch" should support stdin)
  • NX-887 (Additional variables in threshold script)
  • NX-1388 (Event correlation route should start at proxy)
  • NX-1536 (No output from forced status poll without "modify" object access right)
  • NX-1552 (NXSL function to check for EPP timer existence)
  • NX-1558 (Add ability to change node's comment from script)
  • NX-1561 (Unexpected SYS_SNMP_DOWN events after SNMP proxy node restart)
  • NX-1567 (EPP selection gets stuck)
  • NX-1569 (Agent crash on 32 bit Windows 10)
  • NX-1571 (Option to automatically terminate resolved alarms after timeout)

2.2.12

  • Added support for active network discovery in remote zones
  • Database manager options to skip various logs during database export also works for database migration
Fixed issues (3)
  • NX-1206 (Full screen mode with only dashboard elements)
  • NX-1541 (Cannot open dashboard by name using command line option)
  • NX-1542 (Ampersand characters in template path not escaped in exported configuration XML file)

2.2.11

  • New parameter Process.VMRegions in Linux sub-agent
  • nxshell reads password from terminal if not given on command line
  • Housekeeper validates configuration for template DCIs
Fixed issues (12)
  • NX-1499 (Show last N values instead of line chart for string DCIs in alarm details view)
  • NX-1512 (File Manager: Unable to create new directory in root directory on Windows)
  • NX-1513 (Server installation fails with MySQL 8.0)
  • NX-1518 (Variable $object is not set for scheduled scripts associated with object other than node)
  • NX-1519 ("Import dashboard" action not available in dashboard group context menu)
  • NX-1520 (Object Details - Overview tab in desktop client is unusable when using dark gtk3 theme)
  • NX-1521 (Agent crash if file manager cannot resolve user or group name)
  • NX-1522 (Log parser can read file incorrectly during high write activity)
  • NX-1530 (Linux agent do not detect Hyper-V host)
  • NX-1531 (Scripts are not executed during macro expansion in "download file" type object tools)
  • NX-1532 (Agent external table does not handle UTF-8 text correctly)
  • NX-1535 (Auto bind to container is not working if node already is an indirect child of this container)

2.2.10

  • Improved server startup time
  • Added server startup event SYS_SERVER_STARTED
  • New method readInternalParameter in NXSL classes Node, Cluster, MobileDevice
  • Improved cached agent data reconciliation
  • Fixed DCI instance discovery issues
  • Fixed apkg installer script on AIX
Fixed issues (2)
  • NX-1477 (Offline data collection does not cleanup old data if there are no connection with the server)
  • NX-1514 (Predefined graph tree displayed incorrectly)

2.2.9

  • New NXSL functions: Base64Decode, Base64Encode, EventCodeFromName, EventNameFromCode
  • Original event name passed to alarm timeout event as 5th parameter
  • Added information tooltips in switch port view
  • Improved performance of active network discovery
  • Minimum, maximum, and moving average for ICMP response time in ping subagent
Fixed issues (12)
  • NX-1463 (Web UI does not work under Tomcat 9)
  • NX-1475 (Deselected "Create helpdesk ticket on alarm creation" is not being saved in EPP)
  • NX-1486 (NXSL function CreateDCI should allow creation with default retention and poll intervals)
  • NX-1489 (Unreliable MariaDB Connector/C version detection in workaround for MariaDB bug CONC-281)
  • NX-1494 (Release 2.2.8 failed to compile on macOS)
  • NX-1496 (Metrics System.Memory.Physical.Available and System.Memory.Physical.AvailablePerc are implemented inFreeBSD agent)
  • NX-1501 (In test mode $dci variable is not set)
  • NX-1502 (Configuration poll resets SNMP version on node)
  • NX-1503 (Access denied error on attempt to take screenshot even if user has take screenshot access right)
  • NX-1504 (Server crash after compiling library script with syntax error)
  • NX-1505 (Assignment in NXSL global statement ignored if variable already declared as global)
  • NX-1510 (Agent list Net.InterfaceNames not supported on FreeBSD)

2.2.8

  • Delayed actions in event processing policy
  • Raw event data stored in event log
  • New hook scripts: PostObjectCreate and DiscoveryPoll
  • Implemented watchdog functionality for external subagents
  • SNMP port and context can be specified in NXSL function CreateSNMPTransport
  • Fixed Summary DCI table fail when row limit set
  • Fixed menu path creation for Summary DCI Table and folder creation for graph view
  • New command line options for Windows agent installer: /FORCECREATECONFIG, /LOGFILE=, /FILESTORE=, /CONFIGINCLUDEDIR=
  • Server optimization for high load
  • Fixed SQL errors during database import or migration
  • New dashboard element "Port view"
Fixed issues (13)
  • NX-1186 (WebUI does not show objects on geo map)
  • NX-1377 (Can't upgrade sqlite database from version 21.4 to 21.5 with error "Unable to set not null constraint")
  • NX-1435 (AgentTunnelListenPort configuration parameter is missing from config table)
  • NX-1458 (DB upgrade from 0.454 to 0.455 failing for sqlite)
  • NX-1459 (Online upgrade for 22.21 failed on sqlite)
  • NX-1471 (Add option to create node in maintenance mode)
  • NX-1472 (Physical Hyper-V Hosts are reporting as Node Type "Virtual" in 2.2.7)
  • NX-1480 (Varbinds in SNMP Traps restricted to 255 characters)
  • NX-1481 (Configuration option to disable topology based event correlation)
  • NX-1482 (NetXMS server ignoring Syslog and Traps from devices in a Zone which are sending directly to NetXMS server)
  • NX-1484 (Corrupted event messages if MySQL is used as backend database)
  • NX-1488 ("Use active thresholds" checkbox gets checked after clicking on OK in map link properties)
  • NX-1492 (Changes in object status not reflected on geo map)

2.2.7

  • "Convert to hexadecimal string" option for SNMP table columns
  • Improved configuration wizard in Windows server installer
  • New command line option /CONFIGENTRY in Windows agent installer
  • New dashboard element "Object Details" (based on object queries)
  • TCP proxy functionality
  • Improved "Alarm Details" view in management console
  • Added support for agent actions defined in external subagents
  • TCP listener can be disabled in agent configuration file
  • Push connector can be disabled in agent configuration file
  • Virtual nodes detection via agent
  • Basic BIOS and hardware platform information provided by Windows agent
Fixed issues (9)
  • NX-993 (Windows installer should honor current state of services during upgrade)
  • NX-1438 (Increase debug level for thread pool messages)
  • NX-1453 (Windows installer option to disable database upgrade)
  • NX-1455 (Zone UIN in NXSL function CreateNode)
  • NX-1456 (DCI values aggregated on cluster may be incorrect on first few polls after server startup)
  • NX-1460 (Configure does not detect pthread_setname_np on macOS)
  • NX-1464 (Agent connection via proxy is not working for IPv6 destinations)
  • NX-1466 (Line length in agent's external table script limited to 255 characters)
  • NX-1467 (Agent cannot process requests for parameters longer than 255 characters)

2.2.6

  • NXSL based queries in object finder
Fixed issues (2)
  • NX-1395 (Change Object Filter to only search if at least 3 characters have been entered)
  • NX-1451 (Additional configs not loaded on agent startup)

2.2.5

  • Agent tunnel falls back to unbound mode in case of agent certificate validation failure
  • Zone information added to alarm log, event log, SNMP trap log, and syslog
  • Agent returns correct free memory value on Windows
  • Parameter System.Memory.Physical.Cached supported on Windows
Fixed issues (21)
  • NX-333 (Add windows service descriptions for both server and agent)
  • NX-622 (Alerts will not be generated in certain conditions: events, that persist after maintenance and node down after unreachable)
  • NX-640 (File manager should show file owner and permissions)
  • NX-716 (Server configurator on Windows should be marked as require-administrator)
  • NX-922 (Service check template objects disappears after server restart)
  • NX-1097 (Configuration option to ignore alarm's helpdesk state when doing resolve or terminate)
  • NX-1157 (configure --with-dist fails if OpenSSL is not installed)
  • NX-1397 (Implement Windows Update information parameters for Windows 10 and Windows Server 2016)
  • NX-1415 (Windows 10 upgrades break agent tunnels)
  • NX-1417 (File.Size parameter not working for Windows pagefile.sys)
  • NX-1418 (Sort scripts in Execute Server Script dropdown)
  • NX-1419 (AgentTunnels.ProcessUnbound scheduled task should be hidden)
  • NX-1420 (Do not use unmanaged devices with SNMP for MAC resolving)
  • NX-1421 (Configuration poll for node without SNMP and agent always read ARP cache from all SNMP devices in subnet)
  • NX-1427 (Max manual Y values for graphs limited to 2147483647)
  • NX-1431 ("Don't Fragment" option for ping sub-agent)
  • NX-1433 (LDAP timeout blocks internal user database)
  • NX-1434 (Return from function from within foreach loop in NXSL can cause unexpected runtime error)
  • NX-1436 (Write hostname to agent log on startup)
  • NX-1442 (Generic device driver cannot read interface list if device does not support ifNumber MIB object)
  • NX-1446 ( Only one agent policy editor can be opened, if another policy is opened for editing, previous is closed without saving)

2.2.4

  • Portech SMS gateway works correctly with newer gateway versions
Fixed issues (12)
  • NX-1208 (Added filter to alarm list)
  • NX-1295 (MIB Walk from DCI missing Column)
  • NX-1332 (Execution timeout for external parameter provider)
  • NX-1337 (Map link color based on object status)
  • NX-1346 (Unable to select template group on config export)
  • NX-1400 (NetworkMap link can be locked when using bendpoints)
  • NX-1403 (Setting floor plan view from right-click menu does not work)
  • NX-1404 (No source node in events generated by syslog parser)
  • NX-1405 (Agent may crash when parsing Windows event log message)
  • NX-1408 (Object filtering by zone in object browser and object search form)
  • NX-1411 (Server configuration option "UseInterfaceAliases" not working)
  • NX-1413 (Agent may crash when processing external parameters provider's output)

2.2.3

  • Additional information about captured Windows Event Log event passed to the server
  • Improved server startup time
  • Automatic termination of related alarms when DCI is deleted
  • Added attribute isSTP to NXSL class Node
  • File I/O functions in NXSL (disabled by default)
  • Sub-second interval between packets can be configured in PING subagent (down to 10 milliseconds)
Fixed issues (12)
  • NX-1149 (Pass EventRecordID with matched Windows event log record)
  • NX-1258 (Option to pass event data from Windows event log to NetXMS event)
  • NX-1259 (Added NXSL function - FindAlarmByKeyRegex)
  • NX-1363 (Automatic deployment of agent policies)
  • NX-1364 (Automatically create nodes for unbound agent tunnels)
  • NX-1367 (Fix HP aCC compiler warnings)
  • NX-1383 (Minimal interval before generating data collection script error events)
  • NX-1389 (If library script saved with compilation errors it disappears from script list)
  • NX-1392 (Reload log parser without agent restart)
  • NX-1393 (PostgreSQL deadlock on updating raw_dci_data table)
  • NX-1398 (Windows Server 2016 not detected correctly)
  • NX-1399 (Some SQL queries fail when using MariaDB driver because of MariaDB bug CONC-281)

2.2.2

  • Server command line tools working with agents (nxaction, nxap, nxget, nxupload) use encryption by default
  • "Floor plan" display mode for objects on network map
  • Access to zone data in network discovery filters
  • Automatic target configuration in PING subagent
  • Implemented option to display object status map in radial form
Fixed issues (24)
  • NX-513 (add toString() to all data objects in netxms-base)
  • NX-599 (Delete single collected value from a DCI)
  • NX-669 (DRBD monitoring is not working in some configurations)
  • NX-689 (Pass found SNMP configuration while discovery for new node creation)
  • NX-890 (Passive elements in rack)
  • NX-1169 (Encryption is not set by default between agent and server)
  • NX-1297 (Copying Files inside File Manager using CTRL and Drag&Drop is not working)
  • NX-1299 (Add username filter to CountEx() and Process.XXX() parameters in Linux subagent)
  • NX-1306 (Show system FQDN in tunnel manager)
  • NX-1350 (Invert Values option for performance tab DCIs; Performance tab graph configuration is maintained on double-click)
  • NX-1366 (Edit option for "group box" decorations on network maps)
  • NX-1369 (Title not displayed for dashboard element "Rack")
  • NX-1370 (Rack page not displayed correctly when switch between rack objects)
  • NX-1372 (PING subagent is not working)
  • NX-1374 (Element DashboardGroup not displayed in Dashboard perspective)
  • NX-1373 (Error message "Error loading RSA keys from ..." in all server-to-agent command line tools)
  • NX-1375 (Add functionality to switch off multipliers for graphs)
  • NX-1376 (Windows agent reports incorrect OS version on Windows 10)
  • NX-1379 (Rack width calculated incorrectly if only front/back selected)
  • NX-1380 (Database error when node has LLDP ID longer than 63 characters)
  • NX-1381 (Unjustified NXSL errors "cannot do automatic type cast")
  • NX-1384 (Automatic ping target configuration on first data request)
  • NX-1385 (Configurable status colors in UI)
  • NX-1387 (Performance tab graph sorting in not working with groups)

2.2.1

  • Implemented separate access rights for each DCI object
  • Option to read log files using VSS snapshots on Windows
  • Per stage confirmation in database manager during database check
  • Fixed file download cancellation
  • HTTPS support in SMSEagle driver
  • New network map element - text box
  • New debug log format with tags
  • Ability to set debug level per tag or tag mask
  • Improved audit logging on object creation
  • NXSL function GeoLocation replaced with GeoLocation class constructor
  • Optimized object updates in database (to reduce load on database in large installations)
  • Thread pool used for data collection instead of fixed number of poller threads
  • Optimized data collection from agents
  • Configurable number of records per transaction for writing DCI data
Fixed issues (23)
  • NX-662 (New network map element - text box)
  • NX-703 (Export/Import actions)
  • NX-757 (Instance discovery - grace period for removed instances before deleting DCIs)
  • NX-801 (Deleted nodes not removed from trusted nodes lists of other objects)
  • NX-1045 (Add rack/chassis diagram as dashboard element)
  • NX-1142 (Back view for racks)
  • NX-1201 (Discovered node links on map should automatically be set to color based on the status of the interfaces shown in connector names)
  • NX-1252 (Fix automatically generated transformation scripts for 64 bit interface counters)
  • NX-1268 (Do DNS resolve for node names via zone proxy)
  • NX-1289 (Override PollCountForStatusChange at Node level)
  • NX-1292 (Option for line charts to not always use 0 as base)
  • NX-1336 (Cluster DCI Max/Min aggregation returns value from last node instead of expected max/min)
  • NX-1339 (JIRA restricts subject field to 254 chars, helpdesk integration should trim alarm text or move reset of the message to issue description)
  • NX-1341 (Scheduled tasks enabled/disabled indicator)
  • NX-1342 (Increase text length limit in SMS sender)
  • NX-1343 (Server crash on re-enabling temporary disabled user)
  • NX-1344 (Search Bar for Agent Tunnel Manager)
  • NX-1345 (Add rule number to EPP export)
  • NX-1347 (New agent parameter File.LineCount)
  • NX-1348 (Continuous warnings in server log: seed object 0 cannot be found)
  • NX-1357 (Line chart is now opened on double clicking a Performance Chart)
  • NX-1359 (Last location in World Map is now saved)
  • NX-1361 (Data type of transformation script's input value can be incorrect)