NetXMS 2.0 release notes

2.0.6

  • Fixed incorrect interface network mask reported by agent on Windows XP and Windows Server 2003
  • Added option to turn off quotes in AT+CMGS command in generic SMS driver
  • Improved compatibility with different GSM modem types in generic SMS driver
  • Fixed SQL errors when saving LDAP users to database
  • Fixed excessive temporary files creation by web UI
  • Fixed build errors on Solaris 11
  • Fixed memory leak in Oracle DB driver
  • Fixed bug in SNMP transport causing false timeout errors
  • New agent metrics for self-monitoring:
    • Agent.Proxy.ActiveSessions
    • Agent.Proxy.ConnectionRequests
    • Agent.Proxy.IsEnabled
    • Agent.SNMP.IsProxyEnabled
    • Agent.SNMP.IsTrapProxyEnabled
    • Agent.SNMP.Requests
    • Agent.SNMP.Responses
    • Agent.SNMP.ServerRequests
  • Management console:
    • Fixed glitches in table value view
Fixed issues (8)
  • NX-545 ("Export to CSV" file save dialog use incorrect file mask (*.* instead of *.csv))
  • NX-614 (Agent parameter list not retrieved when using a proxy)
  • NX-639 (User management changes and upgrades)
  • NX-768 (Ctrl+a and Filter in node's Interfaces tab)
  • NX-1025 (Segfault)
  • NX-1028 (If mail encoding set to utf-8 mail body encoded incorrectly)
  • NX-1029 (gps_history_%d table not dropped when node is deleted)
  • NX-1031 (Bug with displaying cross(remove field) in edit table threshold)

2.0.5

  • Data collection script can return null to indicate data collection error
  • Added option to set type of each varbind in nxsnmpset
  • Fixed memory leak in PostgreSQL database driver
  • New attributes source and sourceId in NXSL class Event
  • New method toJson() in NXSL class Event
  • LVM monitoring parameters on AIX
  • Added option to get normalized server thread pool load average
  • Fixed bug in self-monitoring termplates
  • Management console
  • Fixed possible deadlock when executing server script
  • Fixed area charts on dashboards
  • "Interactive" option for line chart dashboard elements
Fixed issues (5)
  • NX-799 (Support 64bit interface counters on 64bit Linux)
  • NX-820 (Set SYS_TABLE_THRESHOLD_ACTIVATED and SYS_TABLE_THRESHOLD_DEACTIVATED as default in table threshold editor)
  • NX-997 (Force poll on DCI with custom schedule)
  • NX-1005 (Agent and server can write garbage instead of program name to syslog)
  • NX-1010 (NXSL function FindObject returns NetObj object for interfaces)

2.0.4

  • New parameters in Linux platform subagent to get additional CPU information (frequency, model, etc.)
  • Fixed bugs in LLDP based network topology discovery
  • Correct notifications on threshold script errors
  • Option to use last known value for cluster data aggregation in case of data collecion failure
  • Added server configuration parameter to ignore syslog message timestamps and always use server time
  • Added option to disconnect existing sessions of same user on login
  • NXSL: implemented compound assignment operators and prefix increment/decrement for array elements
  • NXSL: can access event parameters as event object attributes (like $event->$1 or $event->instance)
  • Management console
  • Improved dashboard gauge widget
  • Added translucence option for dashboard line charts
  • Configurable display format for dashboard elements data sources
  • Improved inverted line chart support
  • DCI filter in DCI selection dialog
  • Configurable line width on ad-hoc line charts
  • Object tooltips in rack view
  • Line/area switch for all DCIs on chart level
  • Android console
  • Reorganized alarm notification section (issue NX-963)
Fixed issues (18)
  • NX-280 (NXSL, ++ and += on array elements)
  • NX-567 (GetEventParameter issue)
  • NX-647 (Graph stacking only works on non inverted sources)
  • NX-765 (Agent Action - parameters not passed from object tool)
  • NX-866 (Linux NetXMS agent stops working.)
  • NX-892 (One check-box to "Area-chart" all DCIs on graph)
  • NX-955 (Remove deprecated table policy_time_range_list)
  • NX-963 (Refactoring of alarms notification)
  • NX-964 (DCI filter in DCI selection dialog)
  • NX-965 (Incorrect handling of VRRP MAC addresses)
  • NX-966 (Events got duplicated on template auto import)
  • NX-969 (Cannot select objects on map if zoom is not 100%)
  • NX-977 ((web) Exception in Server configuration -> new)
  • NX-978 (Suggested rack display improvements)
  • NX-981 (line width on graphs)
  • NX-986 (Add double click for schedule edit)
  • NX-990 (Agent cache not working if server is not configured as master server)
  • NX-1223 (Support multiple seed nodes per map)

2.0.3

  • Additional parameters in Oracle subagent for redo logs and ASM monitoring
  • NXSL: variable $errormsg holding error description set in catch block
  • New NXSL function SplitString
  • NXSL: new methods setExpectedState and setExcludeFromTopology in Interface class
  • Default interface expected state can be configured
  • GPS subagent (provides location data from NMEA compatible GPS receivers)
  • Server can update node location using GPS subagent
  • Fixed error while event alarm linking multiple times
  • Fixed server hang on shutdown
  • NetXMS processes uses LC_CTYPE from environment for terminal I/O
  • Fixed bug in saving service checks
  • Fixed server crash caused by heap corruption in MS SQL and DB/2 database drivers
  • Fixed server deadlock caused by simultaneous use of instance discovery and transformation scripts
  • Agent parameters for monitoring System V message queues
  • New action User.ChangePassword in WINNT subagent
  • Text2reach SMS driver improved
  • Port check subagent can be configured to return negative value as response time in case of error
  • Management console:
    • Fixed grid issues in network maps
    • Fixed object selection issues in network maps
    • Added "hide links" option on network maps
    • Added support for MAC addresses in format xxx.xxx.xxx.xxx
Fixed issues (15)
  • NX-733 ("Show object details" from DCI summary table)
  • NX-745 (Show Threshold value in DCI Configuration)
  • NX-769 (Default Expected State of Interface handling)
  • NX-829 (Change default legend position to "bottom")
  • NX-882 (Windows agent fails to parse/process some events.)
  • NX-902 (Object overview show expected state interface)
  • NX-909 (Setting for age of source data when alarm is created (for data reconciliation))
  • NX-913 (Maintenance mode from Summary Tables)
  • NX-923 (Agent can crash on Solaris when one of CPUs taken offline)
  • NX-924 (NXSL: DCI-related functions (FindDCIByName, etc.) fail on cluster nodes)
  • NX-929 (It should be possible to execute agent action on node behind proxy)
  • NX-938 (Add the option "fromPhone" for drivers websms)
  • NX-941 (Add option to enter and leave maintenance mode form nxsl script)
  • NX-944 (Java API connect() timeout)
  • NX-947 (No script error event when script uses "use" with non-existent library script)

2.0.2

  • Optimized LDAP synchronization for large directories
  • Added NXSL API for manipulating object geolocation
  • Fixed bug that allows to crash server remotely by sending garbage to client connector port
  • NXSL: new hash map attributes keys and values
  • Object custom attributes can be accessed as hash map in NXSL
  • New server debug console commands log and logmark
  • Management console:
    • Improved file transfer error handling
    • Double click on geo map zoom in and center map on point under cursor
  • Android Console:
    • Updated ACRA library: now crash reports are sent via e-mail (will use the app installed on device to send mail)
    • Fixed bug in action bar commands: disconnect and exit sometimes wasn't working
  • Android Agent:
    • Updated ACRA library: now crash reports are sent via e-mail (will use the app installed on device to send mail)
Fixed issues (10)
  • NX-823 (F2 to rename objects in Object Tree)
  • NX-830 (Show template name with template groups as a path)
  • NX-873 (Improve isPrinter detection)
  • NX-891 (Maintenance mode doesn't work on subnet objects.)
  • NX-895 (Server may crash under heavy load if user logs in when objects being deleted from database)
  • NX-903 (NXSL functions to manipulate node location)
  • NX-906 (PollCountForStatusChange no longer has effect after upgrading to latest stable version)
  • NX-911 (ServiceResponseTime parameter can return 1 as error which can be interpreted as actual response time)
  • NX-912 (World map - zoom to cursor location, not to middle of map)
  • NX-915 (AIX(?) subagent should check if FileSystem.Total is -1)

2.0.1

  • Fixed random server crash if ODBC database driver is used
  • Fixed incorrect reading of long text fields by MS SQL database driver
Fixed issues (2)
  • NX-833 ("Thresholds" tab should be shown on clusters)
  • NX-844 (Android client graph problems)

2.0

  • Template import correctly handles updates for existing templates
  • Scripts can be used as instance source in instance discovery DCIs
  • NXSL node object attribute snmpSysDescription renamed back to sysDescription
  • Selectors in NXSL
  • Array attributes in NXSL: size, minIndex, maxIndex
  • Hash map attributes in NXSL: size
  • New NXSL function: mapList
  • Subnet mask for synthetic subnets can be set in server configuration
  • Added cumulative counters for server DB writer requests
  • Fixed data corruption issues in ODBC and Oracle DB drivers
  • Additional internal server metrics for monitoring DB activity and performance
  • Added interface creation hook
  • Improved System.InstalledProducts table handling on Windows
  • Fixed inefficient query in Oracle monitoring subagent
  • Server shutdown speed improved
  • Faster SNMP probing during configuration polls
  • Fixed false negative in node down detection if expected state of some interfaces set to IGNORE
  • Agent SNMP proxy improved
  • Improved agent data cache reconciliation
  • Fixed Oracle 12c compatibility issues
  • Automatic configuration import from templates directory on server startup
  • Fixed address list configuration bug
  • Management console:
    • Object tool input fields can be rearranged
    • Line width can be configured for line charts on dashboards
    • Column sizes saved in table DCI last values view
    • Rack height and numbering direction can be changed
  • Android Console:
    • Refactoring of Alarms configuration section: alarm notification events fully customizable, added notify by vibration (SOS pattern) and by LED color (set to black to disable a specific category)
    • Added action buttons in status bar for notification icon (reconect, disconnect and exit), only for Android version starting from v4.1
    • Updated support library
  • Android Agent:
    • Support for Marshmallow devices (v6.0)
    • Updated support library
Fixed issues (33)
  • NX-171 (Add empty hook scripts to configuration library)
  • NX-635 (Add "last communication with agent" timestamp to Overview tab)
  • NX-637 (Disable a map object filtering script by checkbox deletes the script)
  • NX-731 (Ability to move Object Tool Input Fields)
  • NX-746 (Default EPP rules for SNMP and Agent un-responsiveness)
  • NX-747 (Agent List - Interface name list)
  • NX-749 (newly created DB is inconsistent (SQLite only?))
  • NX-750 (Server ignores agent cache mode settings for DCIs with source node set)
  • NX-754 (Client library compilation script package.cmd for Windows is broken)
  • NX-756 (Show interface operational status in UI)
  • NX-759 (Default EPPs for SYS_THREAD_HANG and SYS_THREAD_RUNNING)
  • NX-760 (Hook::InterfaceAcceptFilter)
  • NX-761 (Server config parameter for default subnet size)
  • NX-764 (Maintanance mode - default EPPs and visualization)
  • NX-772 (Tables (empty) on cluster shown even is aggregation is disabled for DCI)
  • NX-778 (Dashboard import do not match "Table Value" element)
  • NX-783 (Ability to skip collected data export during "nxdbmgr export")
  • NX-784 (Internal DCI "AgentStatus" is supported only if agent is present on the node)
  • NX-785 (Show maintenance mode status in object browser)
  • NX-794 (When table inside dashboard can't load data (invalid DCI, etc.) – console error message is displayed)
  • NX-800 (Can't create dashboard with more than 8 columns)
  • NX-805 (Table::addRow() in nxsl return null empty value instead of row id)
  • NX-810 (mysql query error)
  • NX-813 (System.Memory.Physical.Available reports wrong values)
  • NX-839 (Crash on server shutdown)
  • NX-851 (Slow server shutdown)
  • NX-852 (Template auto-apply script is lost if auto-apply is disabled)
  • NX-854 (SQL errors on Oracle 12c)
  • NX-861 (Housekeeper doesnt delete empty subnets in multi-zone deployment)
  • NX-862 (VPN connector is not saved if subnets are not specified)
  • NX-863 (EPP rules not saved to DB after import)
  • NX-864 (Empty DCIs return "" string instead of null to calling NXSL functions)
  • NX-865 (FileSystem.Volumes vs. FileSystem.Type() inconsistency)