Menu

Show posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Show posts Menu

Messages - Victor Kirhenshtein

#931
Announcements / NetXMS 3.3 patch release 3.3.350
June 05, 2020, 03:03:06 PM
Hi all!

We just published patch release 3.3.350 for version 3.3. It contains multiple minor fixes accumulated over last few weeks and partially already published for specific components. Full change log since initial 3.3 release:

- Replace backslash and comma as part of host and DCI names normalizing in InfluxDB driver
- Fixed bug in socket error reporting for agent tunnels
- Fixed VMGR subagent crash
- Fixed bug in agent policy deployment in 2.x compatibility mode
- Fixed bug in database export
- Fixed bugs in SIP registration testing in Asterisk subagent
- Fixed memory leak in Asterisk subagent
- Fixed bug in template import on server startup
- Fixed server crash on agent certificate renewal
- Fixed server crash when proxied SNMP device responds with "UDP port unreachable"
- Added driver for Moxa industrial routers
- Fixed issues:
        NX-1575 (Ability to duplicate event configuration)
        NX-1780 (Unable to add file to file delivery policy in management console on MacOS)
        NX-1839 (Show alarm key in Alarm Details)
        NX-1844 ('Get list of agent sessions' error in nxmc and webui)
        NX-1845 (Context menu for Service Root shows Create sensor twice)
        NX-1855 (NETXMS_FILE_STORE environment variable not using FileStore agent setting)
        NX-1868 (Zone SNMP Configuration SNMP v3 "Modify" button spelt incorrectly)
        NX-1869 (Environment variables in file delivery policy expanded on save)

Best regards,
Victor
#932
Есть старый feature request на эту тему: https://track.radensolutions.com/issue/NX-470. По идее добавить несложно, можно будет сделать в 3.4 или 3.5.
#933
Это отдельный war файл который можно так-же как и Web UI поставить на любой Java application server (Jetty, Tomcat, etc.).
#934
How server side log looks like for that tunnel? Also, please try this agent version: https://netxms.org/download/releases/3.3/nxagent-3.3.350-x64.exe - it fixes incorrect error code display in "SSL read error" message so we could see actual socket error code that could provide some clue.
Another thought - could it be that you have some kind of DPI device between agent and server that detects SSL handshake and blocks connection for some reason?

Best regards,
Victor
#935
Yes, this should solve the issue. Duplicate records are definitely a bug, but keeping them will not help in debugging it anyway.

Best regards,
Victor
#936
Hi,

it looks like duplicate records in source table, although it is quite strange because PostgreSQL schema should have timestamp as part of primary key as well. Please try to run query

SELECT * FROM idata_164 WHERE item_id=1227 AND idata_timestamp=1589846471;

on original database - how many records it will produce?

Best regards,
Victor
#937
Please check that your server certificate has CA constraint set to TRUE. You can do that by printing certificate in text form with command like this:

openssl x509 -text -noout -in server.crt

and look for "X509v3 Basic Constraints" section. For example, my test server's certificate looks like this (only relevant part of the output):

        X509v3 extensions:
            X509v3 Basic Constraints:
                CA:TRUE


Best regards,
Victor
#938
Hi,

I did some testing on my system, and I can get this error if TCP/IP is disabled in native client configuration. Check "Client Protocols" section under "SQL Native Client 11.0 Configuration" in "SQL Server Configuration Manager".

Best regards,
Victor
#939
Hi,

all seems going well until this point:

2020.06.02 06:04:06.788 *D* [tunnel             ] 192.168.10.6: SSL_write error (bytes=-1 ssl_err=5 errno=2)

SSL error 5 means underlying socket error, which is strange because SSL negotiation seems to be completed successfully. Are you using server version 3.3.x as well? Can you check what was logged in server log during that attempt?

Best regards,
Victor
#940
General Support / Re: Access limited to Dasboards
June 01, 2020, 09:44:12 PM
Hi,

currently no.

Best regards,
Victor
#941
Do you have SYS_DCI_ACTIVE events in event log for that node?
#942
Hi,

configuration looks good. Is hybrid authentication enabled? Also, could it be that password contains some characters that could be misinterpreted (like: ; # ' ")?

Best regards,
Victor
#943
Hi,

server should generate event SYS_DCI_ACTIVE when DCI state changes from "unsupported" to "active". Make sure that you are processing this event in EPP and use correct key to terminate alarms generated with SYS_DCI_UNSUPPORTED.

Best regards,
Victor
#944
Actually we already decided that we have to move from libvirt to direct interaction with VMWare API (as we already did for XEN) - it's just question of available time and resources.

Best regards,
Victor
#945
Попробуйте поставить уровень дебага 9 для тэга ncd.telegram, создать канал, попробовать послать сообщение, и пришлите лог сервера.