Menu

Show posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Show posts Menu

Messages - Victor Kirhenshtein

#7441
Naprimer u menja mnogo pravil takogo vida:

any_host event1 - do actions
any_host event2 - do actions
...
any_host eventN - do actions

I ja hochu iskljuchit' odin konkretnij host iz processinga - ja konechno mogu v kazdom pravile propisat' ego i postavit' "Negate", no proshe do togo sdelat' pravilo

bad_host any_event - stop processing

T.e. mozno ispol'zovat' esli snahala idet specializirovannaja obrabotka eventa dlja hostov, a potom - obschee pravilo dlja vseh ostal'nih. Togda v spec. pravilah stavim "stop processing" i obschee pravilo budet prosche.

Nu i mozno kazdoe pravilo otmechat' flazkom "stop processing" - togda budet logika kak u firewall policy - komu-to eto mozet bit' prosche.
#7442
Pro SNMP - ochen' slozno skazat' bez dopolnitel'noj informacii. Mne takuju situaciju poluchit' ne udalos'. Mozet bit' est' vozmoznost' tcpdump'om sobrat' paketi otsilaemie snmpwalk i nxsnmpwalk chtobi ih sravnit'?
#7443
Hello!

It's just a built-in alias for \PhysicalDisk(_Total)\% Disk Time performance counter. It is the percentage of elapsed time that all disk drives were busy servicing read or write requests. It can be used to measure physical disk load, but it is not related to % of CPU time spent on I/O.

Best regards,
Victor
#7444
Quote from: Alex on February 26, 2008, 02:06:38 PM
Еще одна проблема выскочила. Логинюсь под admin все путем. Но если я логинюсь под обычным пользователем пишет: Unable to connect: Access denied. Хотя в dev2 все работало прекрасно. :( Что интересно такая же бодяга как на рабочем сервере, так и на тестовом :( Менял права юзверям, однофигственно. В чем может быть проблема?

Eto bug, vilozil installer s ispravlennoj konsol'ju.
#7445
Quote from: weec on February 26, 2008, 01:47:49 PM
хотелось бы увидеть изменения RC1->RC2

Primerno vot on:

- move dlja template'ov
- "stop processing" flazok v event processing policy
- nxalarm
- Sinhronizacija imen ob'ektov node s DNS
- Interface names polling

Nu i iz nedodelannogo - advanced event corelation.

I razlichnie melkie izmenenija - no SNMP biblioteku ja vrode kak davno uze ne trogal...
#7446
Quote from: Alex on February 26, 2008, 11:45:28 AM
Нашлась проблема с SNMP

# /usr/local/bin/nxsnmpwalk -c public host .1
SNMP Error: Request timed out

при этом

# snmpwalk -c public host .1
SNMPv2-MIB::sysDescr.0 = STRING: SunOS release:5.8 version:Generic_117350-02 machine:sun4u
SNMPv2-MIB::sysObjectID.0 = OID: SNMPv2-SMI::enterprises.99.1.1.3.34
DISMAN-EVENT-MIB::sysUpTimeInstance = Timeticks: (31764508) 3 days, 16:14:05.08

A esli poprobovat' zadat' versiju: "-v 1" ili "-v 2c" ?
#7447
AlarmViewer uses Internet Explorer to render the information page, and it looks like after upgrade to IE7 something was broken. We are working on a comletely new Alarm Viewer which will replace the old one.

Best regards,
Victor
#7448
Vilozil RC2 v download/rc.

Best regards,
Victor
#7449
Нет такой возможности пока. Сделал в 0.2.20.

С уважением,
Виктор
#7450
General Support / Re: Securing the agent
February 21, 2008, 09:54:24 PM
It should be safe. Agent will accept connections only from hosts listed in configuration file. Connections from all other addresses will be closed immediatelly without sending or receiving any data. Also, you may configure agent to require additional authentication with shared secret, and to require encrypted connections.

Best regards,
Victor
#7451
Yes, then you will get more detailed picture. From my experience, I often configure only common System.IO.DiskQueue parameter on all servers, and then add per disk queue/time for those servers where I see need for more detailed information.

Best regards,
Victor
#7452
Общие вопросы / Re: linux console
February 18, 2008, 09:15:47 AM
Должна. Похоже что у вас wxWidgets собраны под UNICODE, 0.2.19 это не поддерживал. 0.2.20 должен собираться нормально. Пока-что можно попробовать 0.2.20-rc1 или дождаться сегодня-завтра rc2.
#7453
Dolzen bit' bukval'no na dnjah. Menja so vseh storon osazdajut na temu novoj versii :) Ja planiruju v eti vihodnie plotno porabotat' i taki k ponedel'niku ee vidat'.
#7454
General Support / Re: CPU load and utlization
February 14, 2008, 10:59:37 PM
You should use $1 instead of $i. Do you use $1 in when trying short form? Also, you example has syntax error - there are missing ; after return statement.
It should be like this:


sub main()
{
   return ($1 / 2);
}


Best regards,
Victor
#7455
Btw, is there libeay32.dll in NetXMS\bin directory? It supposed to be installed with NetXMS.

Best regards,
Victor