Menu

Show posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Show posts Menu

Messages - Victor Kirhenshtein

#1336
Похоже это следствие ошибки в ReadPersistentStorage - если записи с заданным ключом нет, то возвращается пустая строка, а не NULL. Правильным вариантом кода будет

ReadPersistentStorage($event->dciId . "_0x" . right(d2x($node->id), 8, "0"));

Предварительно можно еще проверить что $event->dciId не NULL.
#1337
Parameter itself is ok, there is 1023 character limit. Problem is with instance value where actual OID will not fit. It is fairly easy to extend instance length limit to 1023 characters as well, I can do that for next release.

Best regards,
Victor
#1338
А точно работает? ReadPersistentStorage на делает подстановку, т.е. будет искаться ключ %<dciId>_%i, а не скажем 127_313.
#1339
Можно помимо генерации аларма делать запись с таким-же ключом в persistent storage, и в правиле отсылки почты по SYS_THRESHOLD_REARMED проверять наличие такого ключа, и только если он есть выполнять отсылку.
#1340
Try to cancel configuration wizard and run initialization manually (using nxdbmgr init) - it may provide more diagnostic information. You can also try to create user and database manually and choose "use existing database" option in configuration wizard.

Best regards,
Victor
#1341
Hi,

make sure that if you are using Windows authentication you have used * as login name and current user has access rights to the database, or if you are using SQL authentication (using login and password) that mixed mode authentication is enabled on SQL Server. Another possible issue could be using IP address (event loopback) with TCP/IP connector not enabled on SQL Server side.

Best regards,
Victor
#1342
Limits are 1023 characters for DCI parameter name and 255 characters for instance name.

Best regards,
Victor
#1343
Hi,

that could indicate that node representing NetXMS server is no longer considered to be local server. You can check that in server debug console - type command

show obj NetXMSServer

and check isLocalMgmt flag value. If this is the case try to find if new node was created to represent NetXMS server.

Best regards,
Victor
#1344
Hi,

currently it's not possible. I've added feature request for ability to pass extra parameters to generated event: https://track.radensolutions.com/issue/NX-1643

Best regards,
Victor
#1345
Hi,

this will require changes in NetXMS SNMP code. I've added feature request for that: https://track.radensolutions.com/issue/NX-1642

Best regards,
Victor
#1346
Hi,

yes, this is known issue fixed in 2.2.13 (crash because of improperly loaded scheduled task).

Best regards,
Victor
#1347
General Support / Re: DCI deletion failure
May 16, 2019, 11:03:52 AM
Hi,

yes, there is a bug in server (buffer overflow). Just fixed it with commit 0b33902b23047427b5d15ca9b70c75ed5571affa. You can rebuild server from source or wait for release 2.2.15 with the fix.

Best regards,
Victor
#1348
General Support / Re: Unable to start Netxms
May 16, 2019, 09:50:06 AM
Hi,

log file does not suggest that service is not started. Try to run with debug level 9. If netxmsd process disappears after start, try to run it under gdb and provide stack trace (output of bt command in gdb).

Best regards,
Victor
#1349
General Support / Re: Connection refused connect
May 16, 2019, 09:48:22 AM
Did netxmsd process gone or it is running but became unresponsive? If latter, please make sure that you have gdb installed and run attached script. It will capture thread stack traces within netxmsd and save them into /tmp. Please provide generated trace file.

Best regards,
Victor
#1350
General Support / Re: Connection refused connect
May 15, 2019, 08:52:49 AM
Hi,

seems to be a bug in the server. What version you are using? Is there core dump for server process?

Best regards,
Victor